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Name
more - text file viewer for Windows

Description
More for Windows is a file viewer that provides UNIX-like regular expression searching and 
movement commands.    Features of More include:

· Multi-document interface (MDI), allowing multiple files to be viewed simultaneously.
· Multiple simultaneous views of the same file.
· Copying of rendered or unrendered text to either the Windows clipboard or filestore.
· Viewing files of unlimited size.
· Text or hexadecimal display, with or without line numbers.
· Configurable fonts for both display and printing.
· Basic regular expression searching.
· Printing and multi-page print preview.
· UNIX more(1) movement commands.
· Text marking and labelled jumps.
More also supports File Manager drag and drop; that is, files can be dragged from the File Manager 
file window and dropped onto the More icon or window.    This operation is equivalent to using the 
Open command on the File Menu.
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Buttons
The Toolbar can be made visible or invisible by selecting Toolbar on the View Menu.    From left to 
right, the toolbar buttons map to the following menu commands:

Open...
Print...
Print Preview

Page Forward
Page Backward
Half-page Backward
Half-page Forward

Search Forward...
Search Backward...
Repeat
GoTo..

Copy...
Set Mark...
Skip to Mark...
Show all Marks
Invoke Editor...

Toggle Line Numbers
Toggle Hexadecimal

About
Help



Configuration
Various configuration options are presented on the Options Menu, including display and printer fonts,
tab length, and the name of an editor that can be invoked directly from More.    Any currently installed
font can be used with More, although note that using proportional fonts with text files may result in 
uneven spacing on the display.

By default, the system font is installed for both displaying and printing, the tab length is set to 8, and 
notepad.exe is nominated as the default editor.    Selecting Save Options on the Options Menu allows
the above defaults to be changed permanently (although note that this can only be done in a 
registered version of WinXs).

Options Menu



Options Menu
Toggle Line Numbers
Toggles line numbers on and off.    If switched on, line numbers are displayed in both text and 
hexadecimal mode, and when printing.

Toggle hexadecimal
Toggles between text and hexadecimal display.

Set Font...
Sets the display font and colors.

Set Printer Font...
Sets the printer font (independent of the setting of the display font).

Set Printer Margin...
Sets the left-hand printer margin in terms of column widths (in the current font and point size).

Set Editor...
Sets the name of the default text editor for use by the Invoke Editor command.

Set Tab Stops...
Sets the default tab length (initially 4).

Save Options
Saves the current option settings (font, printer font, editor, tab stops and current window position) as 
defaults that will be reinstated whenever More is invoked.    To return to the installation defaults, 
delete more.ini from the windows directory.



Copying
More for WIndows provides extensive facilities for copying all or parts of a file to the Windows 
clipboard or filestore.    The amount of text that can be copied to the clipboard is limited to 32kb; any 
amount of text can be copied to filestore.

Copy Dialog
The copy dialog provides the following options:

From (line/mark)
To (line/mark)
Specifies the copy range, which can be input either as absolute line numbers or as text marks, or as 
the special characters . (dot) meaning current line, or $ (dollar) meaning end-of-file.    Lines are 
copied inclusively from the starting line (From) to the terminating line (To).    To copy a single line, 
specify the same line number or text mark for both From and To.    

To select text for copying using the mouse, position the mouse pointer over the first line of text to be 
copied, click and hold-down the left mouse button, drag the mouse over the text to be copied and 
release the mouse button.    The line numbers of the selected lines will be used to initialise the From 
and To fields in the Copy Dialog.

Copy To
Indicates whether copying should take place to the clipboard or to filestore.    If the latter is selected, 
the user will be prompted to supply a name for the output file.

Using
Either the original file text or the displayed (rendered) text can be copied.    Rendering depends on 
which options are currently selected (e.g., line numbers, hexadecimal, etc.), although note that tabs 
are always expanded in rendered text.



Invocation
More for Windows can be invoked either from Program Manager or from the WinXs menu in File 
Manager (if installed).    If a filename is given on the command line, More will open and display the 
contents of that file in its own subwindow.    If no filename is given, the user is presented with the 
standard Windows OpenFile dialog.



Keyboard
The following short-cut keys are defined in this version of More:

Ctrl+C Copy...
Ctrl+O Open...
Ctrl+P Print...
See also:

Movement Comands



Movement Commands
The following movement commands can be selected when a window has input focus:

Menu Item              Key             Meaning

Start-of-File HOME            Skip to first line in file
End-of-File END             Skip to last line in file

Page Forward f (PgDn)        Scroll forward one screen
Page Backward b (PgUp)        Scroll backward one screen
Half-page Forward d (right arrow) Scroll forward half a screen
Half-page Backward u (left arrow)  Scroll backward half a screen
Line Forward j (down arrow)  Scroll forward one line
Line Backward k (up arrow)    Scroll backward one line 

Search Forward /               Search forward for text
Search Backward ?               Search backward for text
Repeat n               Repeat last search
GoTo                   g               Jump to specific line

Skip to Mark '               Jump to specific text mark
Commands Menu
Edit Menu
Searching
Text Marks



Commands menu
Page Forward
Page Backward
Scroll forward/backward one screenful.    The length of a screen depends on the current window size,
the type of rendering currently in effect, and the length of displayed lines.

Half-page Forward
Half-page Backward
Scroll forward/backward one half screenful.    In effect, More will scroll to the middle of the current 
screen (forward) or the middle of the previous screen (backward).

Line Forward
Line Backward
Scroll forward/backward one line, starting from the line at the top of the current screen.    Note that 
this means whole line scrolling, which may result in the scrolling of one or more screen lines.

Start of FIle
End of FIle
Jump to start/end-of-file.    In the case of end-of-file, only the last line of the file will be displayed on 
the output screen.

Search Forward...
Search Backward...
Search forward/backward in the file, starting at the line displayed at the top of the current screen, for 
a line containing the specified regular expression.    If a matching line is found, it will be displayed at 
the top of the next output screen.

Regular Expression
Searching
Repeat
Repeat the last search, in the same direction.

GoTo...
Jump directly to the specified line number.



Regular Expression
A regular expression is made up of ordinary characters and metacharacters.    An ordinary character 
matches itself; for example, the re "aardvark" matches the character sequence 
<a><a><r><d><v><a><r><k> anywhere in an input line.    A metacharacter or metacharacter 
sequence has special meaning as described below.

Metacharacters
 . A dot (.) matches any character.    For example, the re "ab." matches the character sequence 
<a><b><any-character>.

 * An asterisk (*) matches the previous ordinary character, metacharacter or metacharacter 
sequence any number of times.    For example, the re "ab.*" matches the character sequence 
<a><b><any-character...>.

 \ A backslash (\) escapes the following character and is commonly used to escape the meaning 
of a metacharacter.    For example, the re "ab\." matches the character sequence <a><b><.>.

\n This expression matches the same string of characters as was matched by the nth expression 
enclosed between the metacharacter sequence \( and \) (see below for details), appearing earlier in 
the same regular expression. For example, the re "^\(abc\)\1$" matches a line consisting of two 
repeated appearances of the string <a><b><c>.

 ^ A caret (^) anchors a regular expression at the start of an input line.    For example, the re 
"^abc" will only match input lines that start with the character sequence <a><b><c>

 $ A dollar ($) anchors a regular expression at the end of an input line.    For example, the re 
"abc$" will only match input lines that end with the character sequence <a><b><c>.

Metacharacter Sequences
 [...] A bracketed re is a metacharacter sequence that defines a scanset.    A scanset defines single 
characters or character ranges that are matched against the next character in the input line.    For 
example, the re "^[abc]" will match any input line that begins with the characters <a>, <b> or <c>.    A 
character range is denoted by dash (-) separated character sequences; that is, the re "^[a-z]" 
matches any line beginning with a lower-case letter, the re "^[a-zA-Z]" matches any line beginning 
with a lower-case or an upper-case letter.    Within scansets, metacharacters, other than a dash, lose 
their special meaning.    A dash character appearing as the first or last character in a scanset loses its
special meaning and matches itself.    A caret (^) appearing as the first character in a scanset causes 
the scanset to be complemented; that is, the re will match characters NOT specified in the scanset.

\{m,n\} Is a range expression that matches the previous ordinary character or metacharacter a
specified number of times.    The values of m and n must be integers in the range 1-255.    The 
expression \{m\} matches exactly m occurrences; \{m,\} matches at least m occurrences; \{m,n\} 
matches any number of occurrences between m and n inclusive.    Wherever a choice exists, the re 
matches as many occurrences as possible.

\(re\) An re enclosed between \( and \) matches whatever the unadorned re matches.    However, the
enclosed re can also be used for repeating a match (see \n above).



Searching
Searching can be either forward or backward and is performed by matching a specified regular 
expression against either rendered or unrendered text.    Searches are initiated by selecting Search 
Forward, Search Backward or Repeat on the Edit Menu.    In the first two cases, the Search Dialog is 
displayed; in the latter case, the previous search (if any)    is repeated.    Searching stops at the first 
line containing a text pattern that matches the regular expression; that line is then displayed as the 
first line in the output window.

Edit Menu
Regular Expression

Search Dialog
The following options are presented in the search dialog:

Regular Expression
A single or multi-character regular expression identifying the text to search for.

Anchor at start-of-line
Same as the caret (^) single-character regular expression; that is, the search will only match with text
at the start of an input line.

Anchor at end-of-line
Same as the dollar ($) single-character regular expression; that is, the search will only match text at 
the edn of an input line.

Ignore Case
The case of characters is ignored when matching text; that is, the upper-case letters will match their 
lower-case equivalents, and vice versa.

Using
Permits searching to be performed against unrendered or rendered text.    Unrendered text is the text
as contained in the input file; rendered text is the displayed text, with tabs expanded, and optionally 
with line numbers present and/or hexadecimal codes.



Edit Menu
Copy...
Copying
Set Mark...
Skip to Mark...
Text Marks
Show all Marks
Displays a listbox identifying all current text marks and the lines to which they refer.    Optionally, all 
current text marks can be cleared.

Invoke Editor...
Invokes a text editor, passing it the name of the file displayed in the active view window.    The user is
presented with a dialog identifying the editor and the edit file; either or both these values can be 
changed temporarily.    To change the editor permanently, select Set Editor on the Options Menu.    
Note that the editor is run concurrently with More, so text changes are not reflected automatically; re-
open the file to view its contents after editing.

Options Menu



Text Marks
Text marks (or bookmarks) are a way of marking specific positions within the file being viewed.    
More permits 26 such marks per view window, each one identified by a single letter in the range a-z.  
Generally speaking, text marks can be used wherever line numbers may be specified (e.g., when 
copying text).    They are also useful for marking specific passages of text, which can be jumped to 
subsequently by simply specifying the associated text mark.

There are two ways of marking text:

· Select a line of text in the client window using the mouse (i.e., by positioning the mouse pointer 
over the required line of text and clicking the left mouse button), choose Set Mark from the Edit 
Menu, set a mark in the range a-z and click OK.    The indicated text mark will be set to point at 
the selected line of text.

· Without selecting any text, choose Set Mark from the Edit Menu, set a mark in the range a-z and 
click OK.    The indicated text mark will be set to point at the first line of text in the client window.

To display or clear current text marks, select Show All Marks on the Edit Menu.

Edit Menu



Menus
File Menu
Edit Menu
Commands Menu
Options Menu
View menu
Window Menu



File Menu
Open...
Open a file for viewing.    The user is presented with the standard Windows OpenFile dialog, which 
can be used to select the file for opening.    Any number of files can be open concurrently, although 
this may be limited by the amount of available virtual store.

Close
Close the current active file.

Save As...
Save the current active file.    When this option is selected, the standard SaveAs dialog is displayed, 
allowing a name to be given to the output file.

Print...
Print the current active file.    Options are specified using the standard Windows Print dialog.

Printing
Print Preview
Preview the current active file for printing.

Print Setup...
Invokes the standard WIndows Print Setup dialog.

Exit
Exit More for Windows, closing all active files (if necessary).



Printing
More for windows supports file printing and print preview.    The text will be rendered according to the 
current printer font selection, with the current printer margin (see Options Menu) and with the current 
options applied (i.e., line numbers and/or hexadecimal).    Each page is printed with a header as 
defined for the UNIX pr(1) command; that is, date and time of printing, filename and page number.

Note that long lines are truncated rather than wrapped, although the printer orientation can be either 
landscape or portrait.    Also, either the whole document or a subrange of pages can be printed.    Use
print preview to examine print pagination.

Options Menu
Options



Options
When viewing a file, two further options are presented on the Options Menu, as follows:

· Line Numbers.    Lines will be displayed or printed with line numbers, which is the relative number
of each line in the file.

· Hexadecimal.    Lines will be displayed or printed in hexadecimal (rather than as text).    Each line 
will be preceded by the offset of the line within the file, and the length of the line.    Both values 
are given in hexadecimal.

Both the above are toggles, meaning that successive selection causes the option to be switched on 
and off, on and off, etc..    At program start, both toggles are off.

Options Menu



View Menu
Toolbar
Toggles the toolbar on or off.

Status Bar
Toggles the status bar on or off.



Window Menu
New Window
Creates a new view of the current document (file).    Views, even of the same document, operate 
completely independent of one another.    Properties associated with a view include text marks, line 
number and hexadecimal options.    So, for example, it is possible to view the same file in different 
modes (text and hexadecimal), or to view different parts of the same file simultaneously.

Cascade
Cascade current (non-minimised) view windows

Tile Horizontally
Tile Vertically
Tile current (non-minimised) view windows.

Arrange Icons
Arrange minimised view icons along the bottom of the More window.



Viewing
Each open file is viewed in its own subwindow.    Additionally multiple, independent views of the same
file can be created via the New Window option on the Window Menu.    The current window is the 
window with input focus, which can be set by clicking the left-mouse button anywhere in the window, 
or by using the Ctrl+Tab Windows short-cut key.    

Any of the Movement Commands can be specified when a view has the input focus.    Movement 
Commands are available on the Commands Menu, as Toolbar Buttons, and from the keyboard as 
short-cut keys.    Movements can be page at a time, half-page at a time, line at a time, or by 
searching/jumping to specific lines or items of text.    Movements are also defined for jumping to the 
start and the end of a file.    All viewing takes place in the currently selected display font.

Window Menu
Commands Menu
Movement Commands
Keyboard
Buttons
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